Tuesday, February 5, 2008

My First Ever Arena...

...was a 2v2, me (BM hunter) and a warlock vs. a warrior and a priest.

I really didn't know a lot about what I was doing because I'd never even been inside an arena before. Somebody told me I should "run up the ramp" so I did. The warrior started pounding on the warlock first which gave me ample time to pop Beast Within, Abacus of Violent Odds, and Rapid Fire, and start devouring the warrior.

I actually got his health down quite a ways, but, ya know... he had a priest. So it was all to no avail. (In retrospect we probably should've attacked the priest first, but I didn't see him for a while.) I eventually died, which I expected-- I am so geared for PvE right now that it's not even funny how gimped my stamina and resilience are-- but to be honest I did better than I thought I'd do. I guess having 7000+ lifetime honor kills gives me a wee bit of an advantage despite my lack of gear.

I also played ten Arathi Basin games yesterday; I figured "why not" because it was still the holiday weekend for it and also because I had this sudden idea to record the results of the ten games, just for some fun statistics to look at.

Of the ten games I played, all PuGs, seven were against premades and were thus losses. (Though funnily enough, only two of those premades wound up actually five-capping us, the other five were all long grueling battles that lasted just as long as if it hadn't been a premade anyway. One comes to mind where we constantly had two nodes capped and the premade only managed to keep three... they kept trying to take our other nodes, and they kept failing.)

So only three of the games were good ol' fashioned PuG vs. PuG matchups. Of those three games, Alliance won two and Horde won once. For the first Alliance win, the Horde seemed to be off the ball right from the start, Alliance was ahead the entire way and won about 2000-1200. The second Alliance win was actually a very very close race for about 75% of the game, at which point Alliance somehow pulled off some crazy epic 5-cap maneuever and clinched us the victory. The one Horde victory was a pretty resounding Horde victory, they were ahead basically the entire game and it culminated in a 5-cap for them.

All and all I was satisfied; it showed me that despite all the premades you still get the occasional really fun matchups. I've been taking a break from PvP for a while but yesterday may have given me "the bug" again. I need to get some gear, afterall, if I'm going to be doing arena!

And now for something completely different: more and more WoW blogs are being hosted on Wordpress, and that's fine and all except that for some reason, blogs hosted on Wordpress seem to have a lot of issues loading for me. I think it has something to do with "Google Analytics" because that's always what shows up at the bottom of my browser, by the loading bar: "Waiting for Google Analytics". Seriously though, I had a Wordpress blog open in a Firefox tab just now and it took no less than ten minutes to load. They're all like that for me. And it takes me forever to leave a comment at those blogs, for the same reason. =/ Does anybody happen to know what's going on? So many good blogs are hosted on Wordpress and I'd like to make them easier to access.

7 comments:

Gebeorgan said...

I don't know why you're having trouble with Google Analytics but if you get the No Script Firefox add-on you can blitz it globally. A bit sledgehammer / walnut but it'll work.

sonvar said...

Arena as a BM hunter is good since most teams try to do CC at the beginning and after that give up on it. So using TBW you get a headstart on them. 2v2 can be tricky as there are some class duos that will simply outmatch you. My bane in 2v2 has been a resto druid/any dps combo. If we can get the resto druid down quickly we're ok but otherwise those HoTs are become too much to overcome.

Mania said...

That is odd, about Analytics. Do you have similar problems with Google AdSense blocks?

Viktel said...

Not sure whats going on, but I also use firefox and Google Analytics is not allowed.

I have no problems loading wordpress.

Pike said...

I have an Adblock addon, so Google AdSense simply doesn't show up for me at all. I wonder if that might be related to the problem...

Faeldray said...

Are you having problems at my blog? Because I have Google Analytics but no AdSense.

Pike said...

No, I only seem to have problems with Wordpress hosted blogs (blogname.wordpress.com)